Login to platform.grid.ai is temporarily broken

Incident Report for Grid AI

Resolved

This incident has been resolved.
Posted Nov 02, 2021 - 18:52 UTC

Identified

A fix is in progress.
Posted Nov 02, 2021 - 18:02 UTC
This incident affected: Grid Service.